Обратите внимание, что вся информация на этом портале переведена с других языков, поэтому некоторые фразы могут быть неточными. Надеемся на ваше понимание и желаем успешной работы с сайтом! С уважением, создатели сайта. Наша почта: [email protected]

Как установить Java в OS X El Capitan

Некоторым пользователям Mac требуется установить Java в OS X El Capitan, возможно, для совместимости с определенным веб-сайтом или приложением или потому, что они разработчик Java. Но Apple становится все более строгим с Java, и по умолчанию он больше не устанавливается с чистой установкой OS X 10.11, и вы обнаружите, что после обновления Mac предыдущая версия JRE или JDK больше не может функционировать.

Кроме того, при попытке использовать некоторые конкретные приложения или веб-контент вы можете столкнуться с «Это приложение требует устаревшего Java SE 6 runtime, которое недоступно для этой версии OS X». Это сообщение означает, что если вы хотите запустить этот вам понадобится использовать более старую версию Java.

В любом случае, если вам нужна Java JRE или Java JDK в OS X 10.11 или новее, вот как вы можете ее установить.

Чтобы быть ясным, если вам не нужна Java, вы не должны устанавливать Java. И если вы не уверены, нужна ли вам Java или нет, значит, вам вообще не нужна Java, и вы также можете избежать установки java.

Пользователям Mac может потребоваться отключить защиту без корневого доступа SIP в OS X до того, как сможет успешно установить Java, но вы можете включить ее снова после ее установки. Если вы застряли на «проверке …» во время процесса установки Java, это из-за отсутствия rootless.

Установите Java SE 6 в OS X El Capitan из Apple

Вы можете установить устаревшие версии Java в OS X El Capitan с помощью установщика Java для OS X 2015-001, который включает в себя Java 6. Чтобы быть ясным, Java 6 — это версия с 2013 года, она устарела и больше не поддерживается Oracle , он имеет различные известные дыры в области безопасности и поэтому не подходит большинству пользователей Mac для установки без веской причины. Итак, если у вас нет необходимости в Java 6, вы, скорее всего, захотите получить более новую версию, или если вам вообще не нужна Java, просто не устанавливайте ее.

  • Получите устаревшую Java для OS X 2015-001 от Apple

Это загрузит установщик, который вы можете использовать для OS X El Capitan (и Yosemite и Mavericks, если на то пошло).

Если вы столкнулись с ошибками при установке, это связано с тем, что вы просмотрели введение и не отключили SIP / rootless на Mac. Сделайте это первым, и Java установит просто отлично.

Установите Java 8 в OS X EL Capitan из Oracle

Другой вариант — получить самую последнюю доступную версию Java от Oracle. Вы можете запустить это одним из двух способов:

  • Откройте терминал и введите «java -version», затем нажмите кнопку «Дополнительная информация», чтобы перейти на страницу загрузки Java.
  • Или перейдите на страницу загрузки Java прямо здесь, на Oracle.com, где вы можете найти JRE и JDK

Установите java в OS X El Capitan

Опять же, вам, скорее всего, придется отключить защиту SIP на Mac, прежде чем вам будет разрешено завершить установку.

Понравилась статья? Поделиться с друзьями: